2IN1 SILVER LIGHTNING WHEEL SL-6682 DRIVER

Or right-click your My Computer icon and select Properties. Thank you for you solutions. I have some bad news guys. Actually I am fantastic. I have a joystick and the joystick works perfectly Share This Page Tweet.

Uploader: Meztitilar
Date Added: 24 October 2006
File Size: 55.87 Mb
Operating Systems: Windows NT/2000/XP/2003/2003/7/8/10 MacOS 10/X
Downloads: 83860
Price: Free* [*Free Regsitration Required]

I have done this several times in last week but it didnt help and the drivers that you gave me I dont think so that sl-668 are drivers for my wheel So I dont think that a new wheel will solve the problem because on the older computer it works.

Actually I am fantastic. Software This better work!!! Your name or email address: Have you tried all 4 2.

SPEED-LINK SL 2 IN 1 SILVER LIGHTNING WHEEL – ibuy Cyprus

It must be faulty USB ports or you should probably get another wheel. Ha i think it must of been the compatibility issues between the 1.

I have managed to get my wheel to work. It was just my motherboard USB ports weren compatible with my wheel. I have contacted the manufacturer for the wheel and I am waiting for 2kn1 response.

  HP MFP M521DN DRIVER DOWNLOAD

I have a joystick and the joystick works perfectly I would say its a Windows problem but you said you’ve tried installing it on various OS’s. I tried every port on my computer and I have 6 ports, 4 in the back and 2 in the front.

If this wheel works on other computers but not on yours than obviously you have a problem with your hardware unfortunately. If it doesn’t than it MUST be your motherboard that is faulty. In the Properties window, select Device Manager. Share This Page Tweet. I even updated my BIOS but that didnt work either.

Problem with Speedlink SL-6682 Racing wheel

See if you can get another wheel. Sometimes its just compatibility You must log in or sign up to reply here.

I have only 2 USB 2. But I tried them and they didnt work I have some bad news guys. I don’t mean to sound like a bad guy here but it seems to me that the drivers aren’t installed properly, even though you stated that you’ve installed them already. But in the Device Manager the wheel isnt recognized so it is called “Unknown device” when I click properties to uninstall the drivers in the Device Status box is labelled “no drivers installed for this device” Here is the proof that I have installed the driver that you gave me link to Plug in the Wheel and install the drivers from this link: I’m really out of options here buddy.

  CREATIVE SOUND BLASTER AUDIGY 24 BIT 7.1 CHANNEL DRIVER

I have istalled updated drivers for motherboard but it didnt solve the problem.

I am gonna break my computer Thank you for you solutions. I wasnt the OS Problem or something like that. If it is a motherboard issue, i wouldn’t bother buying another one as it would be too costly and a big hassle. Discussion in ‘ General Hardware ‘ started by lightninngJul 23, Or right-click your My Computer icon and select Properties.